[FLASH-USERS] Patch for FLASH4.5 with HDF5 1.10.x

Yingchao Lu yingchao.lu at gmail.com
Thu Dec 21 00:29:35 EST 2017


Hi Klaus,

Thanks for you update. I tested this patch. It works for the LaserSlab
problem with option +hdf5typeio. I checked the data in the output and found
no problem.

Thanks,
Yingchao

On Thu, Dec 14, 2017 at 1:26 PM, Klaus Weide <klaus at flash.uchicago.edu>
wrote:

> On Tue, 12 Dec 2017, Yingchao Lu wrote:
>
> > I tried to build and run lasslab problem in FLASH4.5. The HDF5 version I
> > used is 1.10.0-patch. I got the error as attached.
>
> I have attached a patch, and would appreciate if you could try whether it
> solves the reported problems.
>
> Apply with
>
>   patch -p0 <FLASH4.5-a.diff
>
> in the top FLASH directory (above "source").
>
> Note this applies only to FLASH using HDF5 of versions > 1.8 for I/O.
> People not using such a version of HDF5 (and not planning to) can
> disregard.
>
> IF there are remaining problems when using HDF5 1.10, they might
> be related to the LaserIO feature of the EnergyDeposition unit.
> If that applies, please try turning it off (by setting
> runtime parameter ed_useLaserIO = .FALSE.)
>
> Klaus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://flash.uchicago.edu/pipermail/flash-users/attachments/20171220/0b652354/attachment.htm>


More information about the flash-users mailing list